Difficulty connecting to check status of my delegated tokens

lately, been having great difficulty connecting to check how my delegated tokens are doing with my 7 current delegators…lately, forced to repeatedly attempt to connect and hoping to occasionally luck into a connection… same result if i unlock Metamask before I try connecting or after.
anyone know what the problem/solution might be?

1 Like

Have you tried connecting your wallet to graphtronauts app? https://graphtronauts.com

i have not. not clear what that would do?
i have for many months simply logged into https://thegrah.com/explorer/participants/delegators
connected my metamask wallet
and been able to all details of my account in particular GRT balances, amounts delegated and rewards

now, I almost never able to complete the connection and see my graph account.
very very occasionally, i get a connection.
i am not happy with this obviously.
abe bronchtein

Hi, I think there is something wrong with your MetaMask. Try to install MetaMask in a new browser and let us know if it works.
Or you can use https://www.graphtronauts.com/ app to check your delegations.

1 Like