Problem in testnet node installation

Hi there, I tried to install a test node in my local pc, I have completed test GRT approve and stake on staking contract. Then I followed the instruction here to install indexer agent, service and node with docker:
https://github.com/StakeSquid/graphprotocol-testnet-docker

I went to this step : bash start
All look good:

Successfully built 09b43e8017fa
Successfully tagged graphprotocol-testnet-docker_cli:latest
Recreating cli … done
Recreating alertmanager … done
Recreating index-node-1 … done
Recreating pushgateway … done
Recreating nodeexporter … done
Recreating cadvisor … done
Recreating postgres2 … done
Recreating query-node-0 … done
Recreating index-node-0 … done
Recreating prometheus … done
Recreating nginx-ssl … done
Recreating postgres … done
Recreating nginx-proxy … done
Recreating grafana … done
Recreating vector-node … done
Recreating indexer-agent … done
Recreating indexer-service … done

However, after I tried this:

/shell cli
graph indexer rules get all

It complains:
[Network] request to http://indexer-agent:8000/ failed, reason: getaddrinfo ENOTFOUND indexer-agent

Any idea how to trouble shot this? and what’s going on?

Thanks.

Check the containers are all running and not restarting on a crash with docker container list
Check the logs for the indexer-agent container docker logs --follow --tail 100 indexer-agent

1 Like

Thanks so much. Now it is working.

BTW, how to make my test node visible in explorer?

In addition, now the graph command is working.
But I still have lots of questions. e.g.
Grafana (visualize metrics) http://<host-ip>:3000
But the link doesn’t work for me. So how to check metrics UI?

I found graph doc is still limited. E.g. how to set cost model, if there are some examples ?