Metamask no longer connecting

I have tried everything that old responses to this and similar issues with no results. Metamask shows its connected but Graph will not connect and the button in Graph to connect does nothing. I have tried different browsers, manually connecting MM and clearing all histories. Tried MM support with no results.
My question is do I need some GRT in MM? Any suggestions to solve the connection issue?


@Blksmith The issue is while connecting to subgraph studio right?

Metamask shows its connected but Graph will not connect and the button in Graph to connect does nothing

Does the connect wallet button not turn into a “Sign Message” button?

Hi, That is correct it does not come up and it doesn’t matter if Graph is in MM connected sites or not.


Sorry I didn’t notice the first question…it doesn’t matter which tab. The Explorer, Subgraphs, Network or Participant.

Hi @Blksmith,

It should not matter that there is no GRT in your Metamask wallet. Let’s try to debug this first using one browser. Can you choose either Chrome or Brave browser and share the version number of the browser?

Please help to do the following:

  1. Open the developer tools console on your browser (View > Developer > Developer Tools, select “Console” tab) and visit the site.

  2. Visit The Graph’s app and take a screenshot of your browser and developer tools console window

  3. Click on the “Connect” button on the top right, and select “Metamask” on the modal popup that appears. Take another screenshot of what is shown on your browser and developer tools console window

Please share the above screenshots. Can you also confirm that you are using the Metamask browser extension instead of the Metamask mobile app?


Hello all. I am new to The Graph and want to use the studio, but when I clicked the Sign Message button nothing happened, and the console said “UserProvider.handleLogin() - failure logging the user in Error: Timestamp is not valid” even if I had confirmed the sign request in MetaMask extension immediately.

Hi! Please check that the timestamp on your computer is correct and synced with the real date/time. This issue is normally caused when the time on a machine is not correctly set or auto-synced.


Thanks. My last auto sync happened 2 weeks ago, and says that I am a few seconds late. I toggle the auto sync option in settings, and the sign gets verified now.

I’m having the same issue here. I click on connect, then on metamask, but clicking on metamask does nothing. In metamask app itself, it says connected. If I click to connect to the other wallets, connection options appear.

Can you please help? I’ve been delegated for well over a year, I need to be able to access my delegation.

We consistently have this error in one browser but not in another (both are chrome, they’re just different chrome accounts).

You may try opening incognito or signing in to a new google account if you’re using chrome.

Curious if anyone in here used wallet connect at some point then switched back to metamask. That’s the only immediate thing I can discern that is different between my two browsers.

You are an absolute legend, yep, this worked.

Did you use wallet connect by chance? Glad changing the account/incognito worked for you.

no, haven’t used that, just changed my preferences to allow metamask to open incognito

1 Like