Testnet: Impossibility to link ENS in Display Name under Settings

Dear All,
in Graph Explorer (Testnet) is impossibile to link an ENS name under:
Settings / Public Settings / Display Name

The only way to link our own ENS is via Etherscan using the procedure that I report below.

Is it possible to get this fixed as it can be useful for new indexers joining MIPs?

Thanks so much.

How to setup your ENS in Goerli to be displayed in Graph Explorer
  1. Get your name identifier here by specifying your ENS name (e.g. myfancyname.eth).
    All characters must be lowercase.
  1. Then, go to the smart contract here, and hit the button labelled β€œConnect to Web3”, be sure to be connected with your Main Staking Wallet.

  2. Identify the setDefaultName function and put the values like this:

  • the field β€œ_graphAccount (address)” is your Main Staking Wallet ETH address
  • the field " _nameSystem (uint8)" must be set to 0 (zero)
  • the field β€œ_nameIdentifier (bytes32)” is what you got from the step 1)
  • the field β€˜_name’ is your ENS without the .eth

Then, hit on the Write button to confirm your transaction.
You need to wait for the transaction to end, and in one minute approximately everything will be properly set.


Hey Paolo!
I believe the ability to link your ENS in the Display Name on Testnet Explorer (Goerli) was already enabled ~2 months ago. I have just tried it again myself and was able to update it on the settings page UI.

Could you help to give it a try and just drop me a message on discord if you’re still having issues?