GRT staking problems

Hello everybody,

First of all, I am very new to this and this is my first post. Thanks for having me in the GRT community! I was trying to stake some GRT, but it has never worked.

After connecting Metamask, the tricky point is always to delegate to an indexer, as you can hopefully see in the image uploaded. I could never proceed past step 1: “Allow GRT to be delegated”. I’ve tried different browsers, PC and smartphone, none of it worked.

Do I have too little ETH in my portfolio to cover the fees (around $16 for about 1,000 GRT)?
If anyone knows what is the problem, please let me know. I’m quite certain it is a beginner’s mistake, but being a beginner, I can’t figure out which.



1 Like

sorry about your experience, I think the team will get in touch with you very soon, just give them some time mate.

1 Like

Hi Andy,
Sorry you are experiencing this. I’ll raise this internally.
I faced a similar issue when the ETH in my wallet wasn’t able to cover the transaction.
You could try again with more gas in your wallet.

1 Like

Hi Jerry,

Thanks for the response and the empathy. But If it takes more than $20 in ETH to stake around $100 in GRT, maybe it’s not worth it?

What’s funny, after posting this, someone under the name of Sandeep1 sent me an email message (see photo below). Seeing as there are some errors, I assume this may be a scam. If you come across this, beware.


You can delegate on Arbitrum. It’s significantly cheaper to use the network on Arbitrum

You first need to bridge your GRT to Arbitrum

Thank you again. I’ll do that.